* @copyright 2013-2016 B Hanlon. All rights reserved. * @license MIT http://opensource.org/licenses/MIT * * @link https://shrikeh.github.com/teapot */ namespace Teapot\StatusCode; use Teapot\StatusCode\RFC\RFC2518; use Teapot\StatusCode\RFC\RFC3648; use Teapot\StatusCode\RFC\RFC4918; use Teapot\StatusCode\RFC\RFC5842; /** * Interface representing extended HTTP status codes for WebDAV. These codes are * represented as an interface so that developers may implement it and then use * parent::[CODE] to gain a code, or to extend the codes using static::[CODE] * and override their default description. * * This allows for codes to be repurposed in a natural way where the core, * traditional use would not be meaningful. * * @category StatusCode * * @package Teapot\StatusCode * * @author Barney Hanlon * @copyright 2013-2016 B Hanlon. All rights reserved. * @license MIT http://opensource.org/licenses/MIT * * @link https://shrikeh.github.com/teapot */ interface WebDAV extends RFC2518, RFC3648, RFC4918, RFC5842 { }